We're not experiencing any further problems, and we're continuing to keep a close eye on performance.
Posted Jul 03, 2025 - 13:07 UTC
Monitoring
Performance remains normal and we're continuing to monitor as we investigate.
Posted Jul 03, 2025 - 12:53 UTC
Update
Performance has currently returned to normal, and our team is continuing to investigate the underlying performance problem.
Posted Jul 03, 2025 - 12:40 UTC
Investigating
Some users are currently experiencing difficulties with accessing and logging into their sites on Ghost(Pro). We are looking into this issue now and hope to have everything back to normal shortly.