Reduced Performance on Ghost(Pro)
Incident Report for
Ghost
Resolved
The fix has resolved the issues some customers were experiencing.
Posted
Jul
03
,
2025
-
14:57
UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Jul
03
,
2025
-
14:49
UTC
Update
We're continuing to investigate the situation. A small number of users are periodically experiencing degraded performance for short periods of time.
Posted
Jul
03
,
2025
-
14:21
UTC
Investigating
Some users are again experiencing difficulties with accessing and logging into their sites on Ghost(Pro) - our team is continuing to investigate
Posted
Jul
03
,
2025
-
13:22
UTC
This incident affected: Ghost(Pro).
×
Subscribe to Incident
Subscribe to updates for
Reduced Performance on Ghost(Pro)
via . You'll receive .